WordPress自动升级要求输入FTP信息

换了os后 发现  在WordPress后台自动升级时,或者更新、删除主题或者插件的时候,老是提示需要输入FTP账户信息, 我了去 ,怎么这样,解决方法如下:

方法一、如果使用虚拟主机,可以在wp-config.php里加入下面代码:

define(“FS_METHOD”, “direct”);
define(“FS_CHMOD_DIR”, 0777);
define(“FS_CHMOD_FILE”, 0777);

方法二、如果使用独立服务器或VPS,可以修改网站所在目录属性:

chmod -R 755 /home/wwwroot
chown -R www /home/wwwroot

  其实出现这个的问题就是Apache/Nginx的执行身份非文件属主身份。

解决方法:

  假设你的wordpress安装目录为/home/wwwroot/wordpress

执行:

chown -R www /home/wwwroot/wordpress

  执行上面的命令就可以将/home/wwwroot/wordpress下所有文件的属主改为www,这样就可以解决自动更新必须填FTP的问题。

chown -R www *

就是把目录下所有文件和文件夹的所有者改成叫做www的用户。这样再去尝试WP的自动升级,一键升级就能顺利进行了。

注意:

必须是把wordpress程序文件上传到空间以后再执行该命令,顺序不能颠倒;
添加完虚拟主机以后,也必须把wordpress程序文件上传到空间以后,再执行该命令才有效!