debian; ubuntu; kali / 未分类 · 2015年3月23日

kali 升级后virtualbox 安装不了之Makefile:183: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR= and run Make again

********************
其它相关问题可见我blog 一般参考这两个就行了
debian 升级后virtualbox 启动不了
Installing VirtualBox in Kali Linux Host
virtualbox
apt-get install virtualbox
先到官方下载 二进制包
apt-get -f install
http://www.linuxchina.net/?p=426
系统内核升级至最新,然后安装内核头文件:apt-get install linux-headers-*
##问题
ninstalling old VirtualBox DKMS kernel modules …done.
Trying to register the VirtualBox kernel modules using DKMSError! echo
Your kernel headers for kernel 3.14-kali1-amd64 cannot be found at
/lib/modules/3.14-kali1-amd64/build or /lib/modules/3.14-kali1-amd64/source.
…failed!
(Failed, trying without DKMS)
Recompiling VirtualBox kernel modules …failed!
(Look at /var/log/vbox-install.log to find out what went wrong)
cat /var/log/vbox-install.log
Makefile:183: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR= and run Make again。 停止。
解决
网上都说是 Install Kernel Headers Package 这个思路是没错的,不过网上留传的很多命令在kali 上不能能
过程
[email protected]:~/software$ aptitude search linux-headers
p linux-headers-3.18.0-kali1-all – All header files for Linux 3.18 (meta-package)
p linux-headers-3.18.0-kali1-all-amd64 – All header files for Linux 3.18 (meta-package)
i linux-headers-3.18.0-kali1-amd64 – Header files for Linux 3.18.0-kali1-amd64
i A linux-headers-3.18.0-kali1-common – Common header files for Linux 3.18.0-kali1
p linux-headers-3.18.0-kali3-all – All header files for Linux 3.18 (meta-package)
p linux-headers-3.18.0-kali3-all-amd64 – All header files for Linux 3.18 (meta-package)
i linux-headers-3.18.0-kali3-amd64 – Header files for Linux 3.18.0-kali3-amd64
i linux-headers-3.18.0-kali3-common – Common header files for Linux 3.18.0-kali3
i linux-headers-amd64 – Header files for Linux amd64 configuration (meta-package)
sudo apt-get install inux-headers-3.18.0-kali1-amd64
#这个好像有时要多执行几次
apt-get install virtualbox-dkms dkms -y
apt-get -f install
会连带安装如下Kernel Headers 而 apt-get install -y linux-headers-$(uname -r) 这个匹配出来的不对呢
linux-headers-3.18.0-kali3-amd64 #有点迷惑的是我在 install dkms 时好像有安装后来成功而用的 linux-headers-3.18.0-kali3-amd64 为什么昨天不行,原来是kali1 不是kali3的
linux-headers-3.18.0-kali3-common linux-headers-amd64
linux-kbuild-3.18 virtualbox virtualbox-dkms virtualbox-qt
http://superuser.com/questions/499059/unable-to-install-virtualbox-specify-kern-dir-directory-installing-vir
apt-get install virtualbox-dkms -y
apt-get install dkms -y
/etc/init.d/vboxdrv setup
Kernel Headers Installation
https://forums.kali.org/showthread.php?21494-Kernel-Headers-Installation
Kernel Headers 原来是下面这些呀 apt-get install -y linux-headers-$(uname -r) 这个匹配出来的不对呢
linux-headers-3.18.0-kali3-amd64
linux-headers-3.18.0-kali3-common linux-headers-amd64
linux-kbuild-3.18 virtualbox virtualbox-dkms virtualbox-qt
[email protected]:~# apt-get install -y linux-headers-$(uname -r)
正在读取软件包列表… 完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
E: 未发现软件包 linux-headers-3.14-kali1-amd64
E: 无法按照正则表达式 linux-headers-3.14-kali1-amd64 找到任何软件包
http://www.cnblogs.com/sheldonxu/archive/2012/04/15/2450396.html
Debian / Ubuntu Linux Install Kernel Headers Package
http://www.cyberciti.biz/faq/howto-install-kernel-headers-package/
××××××××××